Задание по Excel - Форум
Воскресенье, 04.12.2016, 04:51
Задачи по информатике
Главная | Регистрация | Вход Приветствую Вас Гость | RSS
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Модератор форума: ignorer, PASCAL26, atvrider 
Форум » Решение задач по информатике » Другие задания » Задание по Excel (Помогите решить до 22.01.11)
Задание по Excel
AlCreedДата: Воскресенье, 16.01.2011, 16:34 | Сообщение # 1
Рядовой
Группа: Новичок
Сообщений: 2
[ 0 ]
Статус: Offline
Даны положительные действительные числа a,b,c. Определить, возможно ли существование треугольника с такими сторонами. Сообщение должно быть "да" или "нет" в приведенной ниже таблице.

Знаю, что делать надо через функцию "если"

a=56, b=10, c=89, Треугольник=?
a=5, b=61, c=5, Треугольник=?
a=44, b=70, c=88, Треугольник=?
a=4, b=45, c=41, Треугольник=?

Посмотрите рисунок, там таблица

Прикрепления: 7478349.png(3Kb)


Сообщение отредактировал AlCreed - Воскресенье, 16.01.2011, 16:34
 
ExcelProfДата: Воскресенье, 16.01.2011, 19:30 | Сообщение # 2
Рядовой
Группа: Новичок
Сообщений: 2
[ 0 ]
Статус: Offline
Для того, чтобы можно было построить треугольник по трем сторонам (a, b и c), необходимо и достаточно выполнения трех неравенств треугольника, а именно: (a+b>c)И(a+c>b)И(b+c>a). Кроме того, из соотношения квадратов длин сторон можно определить тип треугольника. Если c - максимальная из длин сторон, a b и c - длины двух других сторон, то треугольник будет:

прямоугольным при c^2=a^2+b^2
остроугольным при c^2<a^2+b^2
и тупоугольным при c^2>a^2+b^2.

В прилагаемом файле решена Ваша задачка в общем виде.
Если тип треугольника не важен, то нужно оставить только первые 7 столбцов.

 
AlCreedДата: Воскресенье, 16.01.2011, 19:52 | Сообщение # 3
Рядовой
Группа: Новичок
Сообщений: 2
[ 0 ]
Статус: Offline
Честно, спасибо за ответ, но я не понял как всё это делать.

Смысл такой, что надо из данных чисел a,b,c определить есть ли треугольник ("да" или "нет")
И всё это сделать надо в excel, через функцию ЕСЛИ.
Как всё это сделать в программе Excel? Куда и как подставлять данные в функцию?

ExcelProf, что за прилагающий файл?

Сообщение отредактировал AlCreed - Воскресенье, 16.01.2011, 19:54
 
boboДата: Вторник, 18.01.2011, 11:45 | Сообщение # 4
Генерал-майор
Группа: Заблокированные
Сообщений: 42
[ 0 ]
Статус: Offline
предполагается А1, В1 и С1 адреса ячеек со сторонами треугольника а, b и с
в ячейке d пишем:
=ЕСЛИ(A1+B1>C1;ЕСЛИ(A1+C1>B1;ЕСЛИ(B1+C1>A1;"ДА";"НЕТ");"НЕТ");"НЕТ")
 
Форум » Решение задач по информатике » Другие задания » Задание по Excel (Помогите решить до 22.01.11)
Страница 1 из 11
Поиск:

Copyright MyCorp © 2016